Junos Pulse Secure IVE / UAC OS Multiple SSL Vulnerabilities

high Nessus Plugin ID 69987
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

According to its self-reported version, the version of IVE / UAC OS running on the remote host may be affected by multiple vulnerabilities :

- Remote attackers may be able to trigger buffer overflow vulnerabilities on the OpenSSL libraries by sending specially crafted DER data, resulting in memory corruption. (CVE-2012-2131)

- A weakness in the OpenSSL library leaves it vulnerable to an attack that could allow a third party to recover (fully or partially) the plaintext from encrypted traffic. (CVE-2013-0169)

- A flaw in OCSP signature verification in the OpenSSL library allows remote OCSP servers to cause a denial of service condition with an invalid key. (CVE-2013-0166)

Solution

Upgrade to Juniper IVE/UAC OS version 7.1r15 / 7.2r11 / 7.3r6 / 7.4r3 / 4.1r8.1 / 4.2r5.1 / 4.3r6 / 4.4r3 or later.

See Also

https://kb.juniper.net/InfoCenter/index?page=content&id=JSA10591

Plugin Details

Severity: High

ID: 69987

File Name: junos_pulse_jsa10591.nasl

Version: 2.10

Type: remote

Family: Misc.

Published: 9/19/2013

Updated: 7/12/2018

Dependencies: ssh_get_info.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/o:juniper:ive_os, cpe:/a:juniper:junos_pulse_access_control_service, cpe:/a:juniper:junos_pulse_secure_access_service

Required KB Items: Host/Juniper/IVE OS/Version, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/12/2013

Vulnerability Publication Date: 4/24/2012

Reference Information

CVE: CVE-2012-2131, CVE-2013-0166, CVE-2013-0169

BID: 53212, 57778, 60268