FreeBSD : libzrtpcpp -- multiple security vulnerabilities (04320e7d-ea66-11e2-a96e-60a44c524f57)

High Nessus Plugin ID 67249


The remote FreeBSD host is missing a security-related update.


Mark Dowd reports :

Vulnerability 1. Remote Heap Overflow: If an attacker sends a packet larger than 1024 bytes that gets stored temporarily (which occurs many times - such as when sending a ZRTP Hello packet), a heap overflow will occur, leading to potential arbitrary code execution on the vulnerable host.

Vulnerability 2. Multiple Stack Overflows: ZRTPCPP contains multiple stack overflows that arise when preparing a response to a client's ZRTP Hello packet.

Vulnerability 3. Information Leaking / Out of Bounds Reads : The ZRTPCPP library performs very little validation regarding the expected size of a packet versus the actual amount of data received. This can lead to both information leaking and out of bounds data reads (usually resulting in a crash). Information leaking can be performed for example by sending a malformed ZRTP Ping packet.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 67249

File Name: freebsd_pkg_04320e7dea6611e2a96e60a44c524f57.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2013/07/12

Modified: 2013/10/08

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:libzrtpcpp, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/07/11

Vulnerability Publication Date: 2013/06/27

Reference Information

CVE: CVE-2013-2221, CVE-2013-2222, CVE-2013-2223