ModSecurity < 2.7.4 forceRequestBodyVariable Action Handling DoS

High Nessus Plugin ID 67128


The remote web application firewall may be affected by a denial of service vulnerability.


According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.7.4. It is, therefore, potentially affected by a denial of service vulnerability. An error exists related to handling the action 'forceRequestBodyVariable' that could allow an HTTP request to cause a NULL pointer to be dereferenced and an application crash.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to ModSecurity version 2.7.4 or later.

See Also

Plugin Details

Severity: High

ID: 67128

File Name: modsecurity_2_7_4.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Firewalls

Published: 2013/07/02

Modified: 2018/02/02

Dependencies: 67123

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Required KB Items: www/ModSecurity, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/05/10

Vulnerability Publication Date: 2013/05/10

Reference Information

CVE: CVE-2013-2765

BID: 60182

OSVDB: 93687

EDB-ID: 25852