ModSecurity < 2.5.9 Multipart Request Header Name DoS

High Nessus Plugin ID 67125


The remote web application firewall may be affected by a denial of service vulnerability.


According to its banner, the version of ModSecurity installed on the remote host is earlier than 2.5.9. It is, therefore, potentially affected by a denial of service vulnerability. An error exists related to multipart form HTTP POST requests with a missing part header name that could allow an attacker to crash the application.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to ModSecurity version 2.5.9 or later.

See Also

Plugin Details

Severity: High

ID: 67125

File Name: modsecurity_2_5_9.nasl

Version: $Revision: 1.8 $

Type: remote

Family: Firewalls

Published: 2013/07/02

Modified: 2016/10/27

Dependencies: 67123

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Required KB Items: www/ModSecurity, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/03/05

Vulnerability Publication Date: 2009/03/11

Reference Information

CVE: CVE-2009-1902

BID: 34096

OSVDB: 52553

EDB-ID: 8241