FreeBSD : puppet -- Unauthenticated Remote Code Execution Vulnerability (b162b218-c547-4ba2-ae31-6fdcb61bc763)

High Nessus Plugin ID 66966


The remote FreeBSD host is missing one or more security-related updates.


Puppet Developers report :

When making REST api calls, the puppet master takes YAML from an untrusted client, deserializes it, and then calls methods on the resulting object. A YAML payload can be crafted to cause the deserialization to construct an instance of any class available in the ruby process, which allows an attacker to execute code contained in the payload.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 66966

File Name: freebsd_pkg_b162b218c5474ba2ae316fdcb61bc763.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2013/06/23

Modified: 2013/08/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:puppet, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/06/22

Vulnerability Publication Date: 2013/06/13

Reference Information

CVE: CVE-2013-3567