FreeBSD : devel/subversion -- contrib hook-scripts can allow arbitrary code execution (6d0bf320-ca39-11e2-9673-001e8c75030d)

High Nessus Plugin ID 66736


The remote FreeBSD host is missing one or more security-related updates.


Subversion team reports :

The script contrib/hook-scripts/ does not escape argv arguments to 'svnlook' that start with a hyphen. This could be used to cause 'svnlook', and hence, to error out.

The script contrib/hook-scripts/ parses filenames from the output of 'svnlook changed' and passes them to a further shell command (equivalent to the 'system()' call of the C standard library) without escaping them. This could be used to run arbitrary shell commands in the context of the user whom the pre-commit script runs as (the user who owns the repository).


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 66736

File Name: freebsd_pkg_6d0bf320ca3911e29673001e8c75030d.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2013/06/02

Modified: 2013/08/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.1

Vector: CVSS2#AV:N/AC:H/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:subversion, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/05/31

Vulnerability Publication Date: 2013/05/31

Reference Information

CVE: CVE-2013-2088