Apache Tomcat 7.0.x < 7.0.40 Multiple Vulnerabilities

Low Nessus Plugin ID 66428

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the instance of Apache Tomcat 7.0 listening on the remote host is prior to 7.0.40. It is, therefore, affected by multiple vulnerabilities :

- An error exists related to 'AsyncListeners' that throw 'RuntimeExceptions' that allow elements of certain requests to be disclosed in responses to other requests.
(CVE-2013-2071)

- It is possible to upload a malicious JSP to a Tomcat server and subsequently trigger execution of that JSP.
(CVE-2013-4444)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to Apache Tomcat version 7.0.40 or later.

See Also

https://www.securityfocus.com/archive/1/533399/30/0/threaded

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.40

Plugin Details

Severity: Low

ID: 66428

File Name: tomcat_7_0_40.nasl

Version: 1.16

Type: remote

Family: Web Servers

Published: 2013/05/15

Updated: 2018/11/15

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Low

CVSS v2.0

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 3.7

Temporal Score: 3.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/05/09

Vulnerability Publication Date: 2013/05/10

Reference Information

CVE: CVE-2013-2071, CVE-2013-4444

BID: 59798, 69728