CVE-2013-2071

low
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

java/org/apache/catalina/core/AsyncContextImpl.java in Apache Tomcat 7.x before 7.0.40 does not properly handle the throwing of a RuntimeException in an AsyncListener in an application, which allows context-dependent attackers to obtain sensitive request information intended for other applications in opportunistic circumstances via an application that records the requests that it processes.

References

http://archives.neohapsis.com/archives/bugtraq/2013-05/0040.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105855.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105886.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-May/106342.html

http://lists.opensuse.org/opensuse-updates/2013-08/msg00013.html

http://marc.info/?l=bugtraq&m=139344248911289&w=2

http://svn.apache.org/viewvc/tomcat/tc7.0.x/trunk/java/org/apache/catalina/core/AsyncContextImpl.java?r1=1471372&r2=1471371&pathrev=1471372

http://svn.apache.org/viewvc?view=revision&revision=1471372

http://tomcat.apache.org/security-7.html

http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html

http://www.securityfocus.com/bid/59798

http://www.securityfocus.com/bid/64758

http://www.ubuntu.com/usn/USN-1841-1

https://issues.apache.org/bugzilla/show_bug.cgi?id=54178

Details

Source: MITRE

Published: 2013-06-01

Updated: 2017-05-23

Type: CWE-200

Risk Information

CVSS v2

Base Score: 2.6

Vector: AV:N/AC:H/Au:N/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 4.9

Severity: LOW

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
79982GLSA-201412-29 : Apache Tomcat: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
76238RHEL 6 : JBoss Web Server (RHSA-2013:1012)NessusRed Hat Local Security Checks
medium
76237RHEL 5 : JBoss Web Server (RHSA-2013:1011)NessusRed Hat Local Security Checks
medium
75106openSUSE Security Update : tomcat (openSUSE-SU-2013:1306-1)NessusSuSE Local Security Checks
medium
73421Debian DSA-2897-1 : tomcat7 - security updateNessusDebian Local Security Checks
high
72339Oracle Secure Global Desktop Multiple Vulnerabilities (January 2014 CPU)NessusMisc.
medium
69749Amazon Linux AMI : tomcat7 (ALAS-2013-191)NessusAmazon Linux Local Security Checks
low
66670Ubuntu 10.04 LTS / 12.04 LTS / 12.10 / 13.04 : tomcat6, tomcat7 vulnerabilities (USN-1841-1)NessusUbuntu Local Security Checks
medium
66595Fedora 19 : tomcat-7.0.40-2.fc19 (2013-7979)NessusFedora Local Security Checks
low
66530Fedora 17 : tomcat-7.0.40-1.fc17 (2013-7999)NessusFedora Local Security Checks
low
66529Fedora 18 : tomcat-7.0.40-1.fc18 (2013-7993)NessusFedora Local Security Checks
low
800784Apache Tomcat 7.0.x < 7.0.40 Information DisclosureLog Correlation EngineWeb Servers
medium
6833Apache Tomcat 7.0.x < 7.0.40 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
medium
66428Apache Tomcat 7.0.x < 7.0.40 Multiple VulnerabilitiesNessusWeb Servers
low