e107 content_preset.php URI XSS

Medium Nessus Plugin ID 66395

Synopsis

The remote web server hosts a PHP script that is affected by a cross-site scripting vulnerability.

Description

The version of e107 installed on the remote host is affected by a cross-site scripting vulnerability because it fails to properly sanitize user input passed in the URI to the 'content_preset.php' script. An attacker may be able to leverage this to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to version 1.0.3 or later.

See Also

https://seclists.org/bugtraq/2013/Apr/19

https://e107.org/news.php?extend.890.2

Plugin Details

Severity: Medium

ID: 66395

File Name: e107_content_preset_xss.nasl

Version: 1.6

Type: remote

Published: 2013/05/13

Updated: 2019/11/27

Dependencies: 20129

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:e107:e107

Required KB Items: www/e107, www/PHP

Exploit Available: true

Exploit Ease: No exploit is required

Exploited by Nessus: true

Patch Publication Date: 2013/03/14

Vulnerability Publication Date: 2013/04/03

Reference Information

CVE: CVE-2013-2750

BID: 58841

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990