ClamAV < 0.97.8 Multiple Vulnerabilities

medium Nessus Plugin ID 66308
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The antivirus service running on the remote host is affected by multiple vulnerabilities.


According to its version, the ClamAV clamd antivirus daemon on the remote host is earlier than 0.97.8 and is, therefore, potentially affected by the following vulnerabilities :

- An overflow condition exists in the 'getsisstring()' function in 'libclamav/sis.c' when handling SIS content.
This flaw reportedly only affects GNU/Linux.
(Issue 6808)

- A heap overflow exists in the 'libclamav/pdf.c' when handling a specially crafted encrypted PDF file. This flaw reportedly affects ClamAV 0.97.1 - 0.97.7 only.
(Issue 7053)

- A heap overflow exists in 'libclamav/pe.c' that is triggered when handling a specially crafted UPX-packed executable. (Issue 7055)


Upgrade to ClamAV 0.97.8 or later.

See Also

Plugin Details

Severity: Medium

ID: 66308

File Name: clamav_0_97_8.nasl

Version: 1.10

Type: remote

Family: Misc.

Published: 5/3/2013

Updated: 11/27/2019

Dependencies: clamav_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-2020


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:clamav:clamav

Required KB Items: Antivirus/ClamAV/version, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 4/23/2013

Vulnerability Publication Date: 3/12/2013

Reference Information

CVE: CVE-2013-2020, CVE-2013-2021

BID: 59434, 60118