CVE-2013-2020

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Integer underflow in the cli_scanpe function in pe.c in ClamAV before 0.97.8 allows remote attackers to cause a denial of service (crash) via a skewed offset larger than the size of the PE section in a UPX packed executable, which triggers an out-of-bounds read.

References

http://blog.clamav.net/2013/04/clamav-0978-has-been-released.html

http://lists.apple.com/archives/security-announce/2013/Sep/msg00002.html

http://lists.apple.com/archives/security-announce/2013/Sep/msg00004.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-June/109514.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-June/109639.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-June/109652.html

http://lists.fedoraproject.org/pipermail/package-announce/2013-May/105575.html

http://lists.opensuse.org/opensuse-security-announce/2014-12/msg00006.html

http://lists.opensuse.org/opensuse-updates/2013-06/msg00018.html

http://lists.opensuse.org/opensuse-updates/2013-06/msg00020.html

http://secunia.com/advisories/53150

http://secunia.com/advisories/53182

http://support.apple.com/kb/HT5880

http://support.apple.com/kb/HT5892

http://www.mandriva.com/security/advisories?name=MDVSA-2013:159

http://www.openwall.com/lists/oss-security/2013/04/25/2

http://www.openwall.com/lists/oss-security/2013/04/29/20

http://www.securityfocus.com/bid/59434

http://www.ubuntu.com/usn/USN-1816-1

https://bugzilla.clamav.net/show_bug.cgi?id=7055

https://github.com/vrtadmin/clamav-devel/commit/270e368b99e93aa5447d46c797c92c3f9f39f375

Details

Source: MITRE

Published: 2013-05-13

Updated: 2015-09-28

Type: CWE-189

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:11.10:*:*:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:*

cpe:2.3:o:canonical:ubuntu_linux:13.04:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:suse:linux_enterprise_server:11.0:sp1:*:*:*:*:*:*

cpe:2.3:o:suse:linux_enterprise_server:11.0:sp2:*:*:*:*:*:*

Configuration 3

OR

cpe:2.3:a:clamav:clamav:0.9:rc1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90:rc1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90:rc1.1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90:rc2:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90:rc3:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.1_p0:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.2_p0:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.3:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.3_p0:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.90.3_p1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91:rc1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91:rc2:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.91.2_p0:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.92:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.92.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.92_p0:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.93:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.93.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.93.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.93.3:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.94:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.94.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.94.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95:rc1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95:rc2:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95:src1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95:src2:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.95.3:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96:rc1:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96:rc2:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96.3:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96.4:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.96.5:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97:rc:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97.1:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97.2:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97.3:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97.4:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:0.97.5:*:*:*:*:*:*:*

cpe:2.3:a:clamav:clamav:*:*:*:*:*:*:*:* versions up to 0.97.7 (inclusive)

Tenable Plugins

View all (14 total)

IDNameProductFamilySeverity
75004openSUSE Security Update : clamav (openSUSE-SU-2013:0881-1)NessusSuSE Local Security Checks
medium
74051GLSA-201405-08 : ClamAV: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
69932Mac OS X : OS X Server < 2.2.2 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
69878Mac OS X Multiple Vulnerabilities (Security Update 2013-004)NessusMacOS X Local Security Checks
critical
67295Fedora 17 : clamav-0.97.8-2.fc17 (2013-10980)NessusFedora Local Security Checks
medium
67294Fedora 18 : clamav-0.97.8-2.fc18 (2013-10953)NessusFedora Local Security Checks
medium
67289Fedora 19 : clamav-0.97.8-2.fc19 (2013-10853)NessusFedora Local Security Checks
medium
66956SuSE 10 Security Update : clamav (ZYPP Patch Number 8606)NessusSuSE Local Security Checks
medium
66953SuSE 11.2 / 11.3 Security Update : clamav (SAT Patch Numbers 7821 / 7915)NessusSuSE Local Security Checks
medium
66454Fedora 18 : clamav-0.97.8-1.fc18 (2013-8047)NessusFedora Local Security Checks
medium
66314Ubuntu 10.04 LTS / 11.10 / 12.04 LTS / 12.10 / 13.04 : clamav vulnerabilities (USN-1816-1)NessusUbuntu Local Security Checks
medium
66308ClamAV < 0.97.8 Multiple VulnerabilitiesNessusMisc.
medium
6782ClamAV < 0.97.8 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
66286Mandriva Linux Security Advisory : clamav (MDVSA-2013:159)NessusMandriva Local Security Checks
medium