phpMyAdmin 3.5.x < 3.5.8 tbl_gis_visualization.php Multiple XSS

Medium Nessus Plugin ID 66203


The remote web server hosts a PHP application that is affected by multiple cross-site scripting vulnerabilities.


According to its self-identified version number, the phpMyAdmin 3.5.x install hosted on the remote web server is earlier than 3.5.8 and is, therefore, affected by multiple cross-site scripting vulnerabilities. The flaw exists in the 'visualizationSettings[width]' and 'visualizationSettings[height]' parameters of the 'tls_gis_visualization.php' script. An unauthenticated, remote attacker, exploiting this flaw, could execute arbitrary script code in a user's browser.


Either upgrade to phpMyAdmin 3.5.8 or later, or apply the patches from the referenced link.

See Also

Plugin Details

Severity: Medium

ID: 66203

File Name: phpmyadmin_visualization_multiple_xss.nasl

Version: 1.7

Type: remote

Published: 2013/04/24

Updated: 2019/12/04

Dependencies: 17219

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-1937

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 6.1

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, www/phpMyAdmin, Settings/ParanoidReport

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 2013/04/03

Vulnerability Publication Date: 2013/03/31

Reference Information

CVE: CVE-2013-1937

BID: 58962

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990