MySQL 5.6.x < 5.6.11 Multiple Vulnerabilities

Medium Nessus Plugin ID 66179

Synopsis

The remote database server may be affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is 5.6.x older than 5.6.11. As such, it is reportedly affected by vulnerabilities in the following components :

- Data Manipulation Language
- Information Schema
- InnoDB
- MemCached
- Prepared Statements
- Server Install
- Server Locking
- Server Options
- Server Optimizer
- Server Partition
- Server Privileges
- Stored Procedure

Solution

Upgrade to MySQL version 5.6.11 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-11.html

http://www.nessus.org/u?99e05252

http://www.nessus.org/u?b1facedf

Plugin Details

Severity: Medium

ID: 66179

File Name: mysql_5_6_11.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 2013/04/22

Updated: 2019/11/27

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-2378

CVSS v2.0

Base Score: 6

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/16

Vulnerability Publication Date: 2012/12/01

Reference Information

CVE: CVE-2013-1502, CVE-2013-1506, CVE-2013-1511, CVE-2013-1523, CVE-2013-1532, CVE-2013-1544, CVE-2013-1566, CVE-2013-1567, CVE-2013-1570, CVE-2013-2375, CVE-2013-2376, CVE-2013-2378, CVE-2013-2381, CVE-2013-2389, CVE-2013-2391, CVE-2013-2392, CVE-2013-2395, CVE-2013-3794, CVE-2013-3801, CVE-2013-3805, CVE-2013-3808

BID: 59173, 59188, 59201, 59205, 59207, 59209, 59211, 59215, 59216, 59224, 59225, 59227, 59229, 59232, 59237, 59239, 59242, 61222, 61227, 61256, 61269