MySQL 5.5 < 5.5.31 Multiple Vulnerabilities

Medium Nessus Plugin ID 66178

Synopsis

The remote database server may be affected by multiple vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.31 and is, therefore, potentially affected by vulnerabilities in the following components :

- Data Manipulation Language
- Information Schema
- InnoDB
- Prepared Statements
- Server
- Server Install
- Server Locking
- Server Options
- Server Optimizer
- Server Partition
- Server Privileges
- Server Replication
- Server XML
- Stored Procedure

Solution

Upgrade to MySQL version 5.5.31 or later.

See Also

https://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-31.html

http://www.nessus.org/u?99e05252

http://www.nessus.org/u?b1facedf

Plugin Details

Severity: Medium

ID: 66178

File Name: mysql_5_5_31.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 2013/04/22

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/16

Vulnerability Publication Date: 2012/12/01

Reference Information

CVE: CVE-2012-5614, CVE-2013-1502, CVE-2013-1506, CVE-2013-1511, CVE-2013-1512, CVE-2013-1521, CVE-2013-1523, CVE-2013-1526, CVE-2013-1531, CVE-2013-1532, CVE-2013-1544, CVE-2013-1552, CVE-2013-1555, CVE-2013-2375, CVE-2013-2376, CVE-2013-2378, CVE-2013-2389, CVE-2013-2391, CVE-2013-2392, CVE-2013-3794, CVE-2013-3801, CVE-2013-3805, CVE-2013-3808

BID: 56776, 59180, 59188, 59196, 59201, 59202, 59207, 59209, 59210, 59211, 59217, 59218, 59224, 59225, 59227, 59229, 59237, 59239, 59242, 61222, 61227, 61256, 61269