MySQL 5.1 < 5.1.69 Multiple Vulnerabilities

Medium Nessus Plugin ID 66177

Synopsis

The remote database server may be affected by multiple vulnerabilities.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.69 and is, therefore, potentially affected by vulnerabilities in the following components :

- Data Manipulation Language
- Information Schema
- InnoDB
- Server
- Server Install
- Server Locking
- Server Optimizer
- Server Options
- Server Partition
- Server Privileges
- Server Types
- Server XML

Solution

Upgrade to MySQL version 5.1.69 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-69.html

http://www.nessus.org/u?99e05252

http://www.nessus.org/u?b1facedf

Plugin Details

Severity: Medium

ID: 66177

File Name: mysql_5_1_69.nasl

Version: 1.9

Type: remote

Family: Databases

Published: 2013/04/22

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/16

Vulnerability Publication Date: 2012/12/01

Reference Information

CVE: CVE-2012-5614, CVE-2013-1506, CVE-2013-1521, CVE-2013-1531, CVE-2013-1532, CVE-2013-1544, CVE-2013-1548, CVE-2013-1552, CVE-2013-1555, CVE-2013-2375, CVE-2013-2378, CVE-2013-2389, CVE-2013-2391, CVE-2013-2392, CVE-2013-3808

BID: 56776, 59180, 59188, 59196, 59202, 59207, 59209, 59210, 59211, 59223, 59224, 59229, 59237, 59242, 61227