Mac OS X : Java for OS X 2013-003

High Nessus Plugin ID 65999

Synopsis

The remote host has a version of Java that is affected by multiple vulnerabilities.

Description

The remote Mac OS X 10.7 or 10.8 host has a Java runtime that is missing the Java for OS X 2013-003 update, which updates the Java version to 1.6.0_45. It is, therefore, affected by multiple security vulnerabilities, the most serious of which may allow an untrusted Java applet to execute arbitrary code with the privileges of the current user outside the Java sandbox.

Solution

Apply the Java for OS X 2013-003 update, which includes version 14.7.0 of the JavaVM Framework.

See Also

http://www.zerodayinitiative.com/advisories/ZDI-13-068/

http://www.zerodayinitiative.com/advisories/ZDI-13-069/

http://www.zerodayinitiative.com/advisories/ZDI-13-070/

http://www.zerodayinitiative.com/advisories/ZDI-13-072/

http://www.zerodayinitiative.com/advisories/ZDI-13-073/

http://www.zerodayinitiative.com/advisories/ZDI-13-075/

http://www.zerodayinitiative.com/advisories/ZDI-13-076/

http://www.zerodayinitiative.com/advisories/ZDI-13-078/

http://www.oracle.com/technetwork/java/javase/6u45-relnotes-1932876.html

http://support.apple.com/kb/HT5734

http://lists.apple.com/archives/security-announce/2013/Apr/msg00001.html

Plugin Details

Severity: High

ID: 65999

File Name: macosx_java_2013-003.nasl

Version: 1.16

Type: local

Agent: macosx

Published: 2013/04/17

Updated: 2018/07/14

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:java_1.6

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/16

Vulnerability Publication Date: 2013/03/06

Exploitable With

Core Impact

Reference Information

CVE: CVE-2013-1491, CVE-2013-1537, CVE-2013-1540, CVE-2013-1557, CVE-2013-1558, CVE-2013-1563, CVE-2013-1569, CVE-2013-2383, CVE-2013-2384, CVE-2013-2394, CVE-2013-2417, CVE-2013-2419, CVE-2013-2420, CVE-2013-2422, CVE-2013-2424, CVE-2013-2429, CVE-2013-2430, CVE-2013-2432, CVE-2013-2435, CVE-2013-2437, CVE-2013-2440

BID: 58493, 59089, 59124, 59131, 59154, 59159, 59166, 59167, 59170, 59172, 59179, 59184, 59187, 59190, 59194, 59195, 59208, 59219, 59228, 59243

APPLE-SA: APPLE-SA-2013-04-16-2

EDB-ID: 24966