PostgreSQL 9.1 < 9.1.9 / 9.2 < 9.2.4 Denial of Service

Medium Nessus Plugin ID 65857

Synopsis

The remote database server is affected by a denial of service vulnerability.

Description

The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.9 or 9.2.x prior to 9.2.4. As such, it is potentially affected by a denial of service vulnerability. An unprivileged user can run commands that could interfere with in-progress backups.

Solution

Upgrade to PostgreSQL 9.1.9 / 9.2.4 or later.

See Also

https://www.postgresql.org/about/news/1456/

http://www.postgresql.org/docs/9.1/static/release-9-1-9.html

http://www.postgresql.org/docs/9.2/static/release-9-2-4.html

https://www.vmware.com/security/advisories/VMSA-2013-0005.html

Plugin Details

Severity: Medium

ID: 65857

File Name: postgresql_cve20131901.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 2013/04/08

Updated: 2018/11/15

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/04

Vulnerability Publication Date: 2013/04/04

Reference Information

CVE: CVE-2013-1901

BID: 58878

VMSA: 2013-0005