PostgreSQL 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 File Deletion

medium Nessus Plugin ID 65855
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by a file deletion vulnerability.


The version of PostgreSQL installed on the remote host is 9.0.x prior to 9.0.13, 9.1.x prior to 9.1.9 or 9.2.x prior to 9.2.4. As such, it is potentially affected by a file deletion vulnerability. A remote, unauthenticated attacker, could damage or destroy files within a server's data directory by requesting a database name that begins with '-'.


Upgrade to PostgreSQL 9.0.13 / 9.1.9 / 9.2.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 65855

File Name: postgresql_cve20131899.nasl

Version: 1.15

Type: remote

Family: Databases

Published: 4/8/2013

Updated: 11/15/2018

Dependencies: postgresql_version.nbin

Risk Information


Risk Factor: Low

Score: 3.4


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 4.8

Vector: AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 4/4/2013

Vulnerability Publication Date: 4/4/2013

Reference Information

CVE: CVE-2013-1899

BID: 58876

VMSA: 2013-0005