PostgreSQL 8.4 < 8.4.17 / 9.0 < 9.0.13 / 9.1 < 9.1.9 / 9.2 < 9.2.4 Multiple Vulnerabilities

Critical Nessus Plugin ID 65854

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 8.4.x prior to 8.4.17, 9.0.x prior to 9.0.13, 9.1.x prior to 9.1.9, or 9.2.x prior to 9.2.4. It therefore is potentially affected by multiple vulnerabilities :

- Enterprise DB's installers for Linux and Mac OS X create a directory and file in '/tmp' with predictable names.
(CVE-2013-1902)

- Enterprise DB's installers for Linux and Mac OS X pass the database superuser password to a script in an insecure fashion. (CVE-2013-1903)

Solution

Upgrade to PostgreSQL 8.4.17 / 9.0.13 / 9.1.9 / 9.2.4 or later.

See Also

https://www.postgresql.org/about/news/1456/

https://www.postgresql.org/docs/8.4/release-8-4-17.html

https://www.postgresql.org/docs/9.0/release-9-0-13.html

http://www.postgresql.org/docs/9.1/static/release-9-1-9.html

http://www.postgresql.org/docs/9.2/static/release-9-2-4.html

Plugin Details

Severity: Critical

ID: 65854

File Name: postgresql_20130404.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 2013/04/08

Updated: 2018/11/15

Dependencies: 11936, 63346

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/04/04

Vulnerability Publication Date: 2013/04/04

Reference Information

CVE: CVE-2013-1902, CVE-2013-1903

BID: 58877, 58882