MySQL 5.1 < 5.1.68 Multiple Vulnerabilities

high Nessus Plugin ID 65733
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.68 and is, therefore, affected by vulnerabilities related to 'yaSSL'. These errors could result in buffer overflows and possibly arbitrary code execution.

Solution

Upgrade to MySQL version 5.1.68 or later.

See Also

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-68.html

http://dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-68.html

https://blogs.oracle.com/sunsecurity/cve-2012-0553-buffer-overflow-vulnerability-in-yassl

http://www.nessus.org/u?c79e27db

Plugin Details

Severity: High

ID: 65733

File Name: mysql_5_1_68.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 3/29/2013

Updated: 11/27/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-1492

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 2/5/2013

Vulnerability Publication Date: 3/19/2013

Reference Information

CVE: CVE-2012-0553, CVE-2013-1492

BID: 58594, 58595