MariaDB 5.5 < 5.5.30 Multiple Vulnerabilities

high Nessus Plugin ID 65732
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB 5.5 running on the remote host is prior to 5.5.30. It is, therefore, potentially affected by vulnerabilities in the following components :

- GIS
- yaSSL

Solution

Upgrade to MariaDB 5.5.30 or later.

See Also

https://www.zerodayinitiative.com/advisories/ZDI-13-251/

https://mariadb.com/kb/en/library/mariadb-5530-release-notes/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-30.html

https://mariadb.atlassian.net/browse/MDEV-4252

Plugin Details

Severity: High

ID: 65732

File Name: mariadb_5_5_30.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 3/29/2013

Updated: 11/27/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2013-1492

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/5/2013

Vulnerability Publication Date: 3/19/2013

Reference Information

CVE: CVE-2013-1492, CVE-2013-1861

BID: 58511, 58595