MariaDB 5.5 < 5.5.28 Multiple Vulnerabilities

high Nessus Plugin ID 65731
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB 5.5 running on the remote host is prior to 5.5.28. It is, therefore, potentially affected by vulnerabilities in the following components :

- GIS Extension
- Server
- Server Installation
- Server Optimizer
- yaSSL

Solution

Upgrade to MariaDB version 5.5.28 or later.

See Also

https://mariadb.com/kb/en/library/mariadb-5528-release-notes/

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-28.html

Plugin Details

Severity: High

ID: 65731

File Name: mariadb_5_5_28.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 3/29/2013

Updated: 11/27/2019

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2012-0553

VPR

Risk Factor: Medium

Score: 5.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/22/2012

Vulnerability Publication Date: 2/5/2013

Reference Information

CVE: CVE-2012-0553, CVE-2012-3160, CVE-2012-3177, CVE-2012-3180, CVE-2012-5060

BID: 56003, 56005, 56027, 57411, 58594