FreeBSD : piwigo -- CSRF/Path Traversal (edd201a5-8fc3-11e2-b131-000c299b62e1)

High Nessus Plugin ID 65624


The remote FreeBSD host is missing a security-related update.


High-Tech Bridge Security Research Lab reports :

The CSRF vulnerability exists due to insufficient verification of the HTTP request origin in '/admin.php' script. A remote attacker can trick a logged-in administrator to visit a specially crafted webpage and create arbitrary PHP file on the remote server.

The path traversal vulnerability exists due to insufficient filtration of user-supplied input in 'dl' HTTP GET parameter passed to '/install.php' script. The script is present on the system after installation by default, and can be accessed by attacker without any restrictions.


Update the affected package.

See Also

Plugin Details

Severity: High

ID: 65624

File Name: freebsd_pkg_edd201a58fc311e2b131000c299b62e1.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2013/03/20

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:piwigo, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/03/18

Vulnerability Publication Date: 2013/02/06

Reference Information

CVE: CVE-2013-1468, CVE-2013-1469