FreeBSD : php5 -- Multiple vulnerabilities (1d23109a-9005-11e2-9602-d43d7e0c7c02)

High Nessus Plugin ID 65623


The remote FreeBSD host is missing one or more security-related updates.


The PHP development team reports :

PHP does not validate the relationship between the soap.wsdl_cache_dir directive and the open_basedir directive, which allows remote attackers to bypass intended access restrictions by triggering the creation of cached SOAP WSDL files in an arbitrary directory.

The SOAP parser in PHP allows remote attackers to read arbitrary files via a SOAP WSDL file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue in the soap_xmlParseFile and soap_xmlParseMemory functions.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 65623

File Name: freebsd_pkg_1d23109a900511e29602d43d7e0c7c02.nasl

Version: $Revision: 1.3 $

Type: local

Published: 2013/03/20

Modified: 2013/06/21

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:php5, p-cpe:/a:freebsd:freebsd:php53, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/03/18

Vulnerability Publication Date: 2013/03/04

Reference Information

CVE: CVE-2013-1635, CVE-2013-1643