LogAnalyzer asktheoracle.php 'query' Parameter XSS

Medium Nessus Plugin ID 65030

Synopsis

The remote web server hosts a PHP script that is affected by a cross-site scripting vulnerability.

Description

The LogAnalyzer install hosted on the remote web server is affected by a cross-site scripting vulnerability due to a failure to properly sanitize user input to the 'query' parameter of the 'asktheoracle.php' script. An attacker can exploit this issue inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to version 3.6.1 or later.

See Also

http://www.nessus.org/u?3cbd5a51

https://seclists.org/bugtraq/2012/Dec/146

Plugin Details

Severity: Medium

ID: 65030

File Name: loganalyzer_asktheoracle_query_parameter_xss.nasl

Version: 1.6

Type: remote

Published: 2013/03/05

Modified: 2018/11/15

Dependencies: 62122

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adiscon:loganalyzer

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/12/19

Vulnerability Publication Date: 2012/12/19

Reference Information

BID: 57012

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990