MariaDB 5.1 < 5.1.67 Multiple Vulnerabilities

High Nessus Plugin ID 64932

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MariaDB 5.1 running on the remote host is prior to 5.1.67. It is, therefore, potentially affected by vulnerabilities in the following components :

- Information Schema
- InnoDB
- Server
- Server Locking
- Server Optimizer
- Server Privileges
- Server Replication

Solution

Upgrade to MariaDB version 5.1.67 or later.

See Also

https://mariadb.com/kb/en/library/mariadb-5167-release-notes/

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-67.html

Plugin Details

Severity: High

ID: 64932

File Name: mariadb_5_1_67.nasl

Version: 1.10

Type: remote

Family: Databases

Published: 2013/02/28

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/30

Vulnerability Publication Date: 2012/12/01

Reference Information

CVE: CVE-2012-0572, CVE-2012-0574, CVE-2012-1702, CVE-2012-1705, CVE-2012-5611, CVE-2012-5612, CVE-2012-5615, CVE-2012-5627, CVE-2013-0375, CVE-2013-0383, CVE-2013-0384, CVE-2013-0385, CVE-2013-0389

BID: 56766, 56768, 56769, 56837, 57385, 57388, 57391, 57405, 57410, 57412, 57414, 57416, 57417

EDB-ID: 23075, 23076