SuSE 10 Security Update : squid (ZYPP Patch Number 8464)

Medium Nessus Plugin ID 64866

Synopsis

The remote SuSE 10 host is missing a security-related patch.

Description

A denial of service problem in Squid via invalid Content-Length headers and memory leaks has been fixed. (CVE-2012-5643 / CVE-2013-0189, SQUID-2012:1)

Solution

Apply ZYPP patch number 8464.

See Also

http://support.novell.com/security/cve/CVE-2012-5643.html

http://support.novell.com/security/cve/CVE-2013-0188.html

http://support.novell.com/security/cve/CVE-2013-0189.html

Plugin Details

Severity: Medium

ID: 64866

File Name: suse_squid-8464.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2013/02/24

Updated: 2019/06/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/o:suse:suse_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2013/02/12

Vulnerability Publication Date: 2012/12/20

Reference Information

CVE: CVE-2012-5643, CVE-2013-0188, CVE-2013-0189