Google Chrome < 25.0.1364.97 Multiple Vulnerabilities

high Nessus Plugin ID 64813
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is a version prior to 25.0.1364.97. It is, therefore, affected by the following vulnerabilities :

- An unspecified memory corruption error exists related to 'web audio node'. (CVE-2013-0879)

- Use-after-free errors exist related to database and URL handling. (CVE-2013-0880, CVE-2013-0898)

- Improper memory read errors exist related to Matroska, excessive SVG parameters, and Skia. (CVE-2013-0881, CVE-2013-0882, CVE-2013-0883, CVE-2013-0888)

- An error exists related to improper loading of 'NaCl'.
(CVE-2013-0884)

- The 'web store' is granted too many API permissions.
(CVE-2013-0885)

- The developer tools process is granted too many permissions and trusts remote servers incorrectly.
(CVE-2013-0887)

- User gestures are not properly checked with respect to dangerous file downloads. (CVE-2013-0889)

- An unspecified memory safety issue exists in the IPC layer. (CVE-2013-0890)

- Integer overflow errors exist related to blob and 'Opus' handling. (CVE-2013-0891, CVE-2013-0899)

- Numerous, unspecified, lower-severity issues exist related to the IPC layer. (CVE-2013-0892)

- Race conditions exist related to media handling and ICU. (CVE-2013-0893, CVE-2013-0900)

- A buffer overflow exists related to vorbis decoding.
(CVE-2013-0894)

- Memory management errors exist related to plugin message handling. (CVE-2013-0896)

- An off-by-one read error exists related to PDF handling. (CVE-2013-0897)

Note that the vendor states that WebKit's MathML implementation has been disabled in this release. This is due to several unspecified, high severity security issues. Successful exploitation of some of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.

Solution

Upgrade to Google Chrome 25.0.1364.97 or later.

See Also

http://www.nessus.org/u?b1f3d1b4

Plugin Details

Severity: High

ID: 64813

File Name: google_chrome_25_0_1364_97.nasl

Version: 1.17

Type: local

Agent: windows

Family: Windows

Published: 2/22/2013

Updated: 12/4/2019

Dependencies: google_chrome_installed.nasl

Risk Information

CVSS Score Source: CVE-2013-2268

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 2/21/2013

Vulnerability Publication Date: 2/21/2013

Reference Information

CVE: CVE-2013-0879, CVE-2013-0880, CVE-2013-0881, CVE-2013-0882, CVE-2013-0883, CVE-2013-0884, CVE-2013-0885, CVE-2013-0887, CVE-2013-0888, CVE-2013-0889, CVE-2013-0890, CVE-2013-0891, CVE-2013-0892, CVE-2013-0893, CVE-2013-0894, CVE-2013-0896, CVE-2013-0897, CVE-2013-0898, CVE-2013-0899, CVE-2013-0900, CVE-2013-2268

BID: 58167, 58318, 59326, 59327, 59328, 59330, 59331, 59332, 59334, 59336, 59337, 59338, 59339, 59340, 59342, 59343, 59344, 59345, 59346, 59347, 59351