CVE-2013-0899

MEDIUM

Description

Integer overflow in the padding implementation in the opus_packet_parse_impl function in src/opus_decoder.c in Opus before 1.0.2, as used in Google Chrome before 25.0.1364.97 on Windows and Linux and before 25.0.1364.99 on Mac OS X and other products, allows remote attackers to cause a denial of service (out-of-bounds read) via a long packet.

References

http://googlechromereleases.blogspot.com/2013/02/stable-channel-update_21.html

http://lists.opensuse.org/opensuse-updates/2013-03/msg00045.html

http://opus-codec.org/downloads/

https://code.google.com/p/chromium/issues/detail?id=160480

https://codereview.chromium.org/11575026

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A16027

https://src.chromium.org/viewvc/chrome/trunk/deps/third_party/opus/src/opus_decoder.c?r1=173498&r2=173497&pathrev=173498

https://src.chromium.org/viewvc/chrome?view=rev&revision=173498

Details

Source: MITRE

Published: 2013-02-23

Updated: 2018-10-30

Type: CWE-189

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM