SuSE 11.2 Security Update : libvirt (SAT Patch Number 7310)

High Nessus Plugin ID 64781


The remote SuSE 11 host is missing one or more security updates.


libvirt was updated to fix the following security issue :

- A flaw was found in the way message freeing on connection cleanup was handled under certain error conditions. A remote user able to issue commands to libvirt daemon could use this flaw to crash libvirtd or, potentially, escalate their privilages to that of libvirtd process. (CVE-2013-0170)

Also following bug has been fixed :

- Add managedSave functions to legacy xen driver (bnc#782311)


Apply SAT patch number 7310.

See Also

Plugin Details

Severity: High

ID: 64781

File Name: suse_11_libvirt-130205.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2013/02/21

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libvirt, p-cpe:/a:novell:suse_linux:11:libvirt-client, p-cpe:/a:novell:suse_linux:11:libvirt-client-32bit, p-cpe:/a:novell:suse_linux:11:libvirt-doc, p-cpe:/a:novell:suse_linux:11:libvirt-python, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2013/02/05

Reference Information

CVE: CVE-2013-0170