FreeBSD : Ruby Rack Gem -- Multiple Issues (fcfdabb7-f14d-4e61-a7d5-cfefb4b99b15)

Medium Nessus Plugin ID 64668


The remote FreeBSD host is missing one or more security-related updates.


Rack developers report :

Today we are proud to announce the release of Rack 1.4.5.

Fix CVE-2013-0263, timing attack against Rack::Session::Cookie

Fix CVE-2013-0262, symlink path traversal in Rack::File


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 64668

File Name: freebsd_pkg_fcfdabb7f14d4e61a7d5cfefb4b99b15.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/02/18

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5.1

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem18-rack, p-cpe:/a:freebsd:freebsd:rubygem19-rack, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/02/17

Vulnerability Publication Date: 2013/02/08

Reference Information

CVE: CVE-2013-0262, CVE-2013-0263