FreeBSD : Ruby -- Denial of Service and Unsafe Object Creation Vulnerability in JSON (c79eb109-a754-45d7-b552-a42099eb2265)

High Nessus Plugin ID 64652


The remote FreeBSD host is missing one or more security-related updates.


Aaron Patterson reports :

When parsing certain JSON documents, the JSON gem can be coerced in to creating Ruby symbols in a target system. Since Ruby symbols are not garbage collected, this can result in a denial of service attack.

The same technique can be used to create objects in a target system that act like internal objects. These 'act alike' objects can be used to bypass certain security mechanisms and can be used as a spring board for SQL injection attacks in Ruby on Rails.


Update the affected packages.

See Also

Plugin Details

Severity: High

ID: 64652

File Name: freebsd_pkg_c79eb109a75445d7b552a42099eb2265.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/02/18

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ruby, p-cpe:/a:freebsd:freebsd:rubygem18-json, p-cpe:/a:freebsd:freebsd:rubygem18-json_pure, p-cpe:/a:freebsd:freebsd:rubygem19-json, p-cpe:/a:freebsd:freebsd:rubygem19-json_pure, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/02/16

Vulnerability Publication Date: 2013/02/11

Reference Information

CVE: CVE-2013-0269