FreeBSD : Ruby -- XSS exploit of RDoc documentation generated by rdoc (d3e96508-056b-4259-88ad-50dc8d1978a6)

Medium Nessus Plugin ID 64646


The remote FreeBSD host is missing one or more security-related updates.


Ruby developers report :

RDoc documentation generated by rdoc bundled with ruby are vulnerable to an XSS exploit. All ruby users are recommended to update ruby to newer version which includes security-fixed RDoc. If you are publishing RDoc documentation generated by rdoc, you are recommended to apply a patch for the documentaion or re-generate it with security-fixed RDoc.


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 64646

File Name: freebsd_pkg_d3e96508056b425988ad50dc8d1978a6.nasl

Version: $Revision: 1.5 $

Type: local

Published: 2013/02/17

Modified: 2013/06/22

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:ruby, p-cpe:/a:freebsd:freebsd:rubygem18-rdoc, p-cpe:/a:freebsd:freebsd:rubygem19-rdoc, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/02/16

Vulnerability Publication Date: 2013/02/06

Reference Information

CVE: CVE-2013-0256