Flash Player for Mac <= 10.3.183.50 / 11.5.502.146 Multiple Vulnerabilities (APSB13-04)

High Nessus Plugin ID 64507

Synopsis

The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Flash Player installed on the remote Mac OS X host is 11.x equal to or earlier than 11.5.502.146, or 10.x equal to or earlier than 10.3.183.50. It is, therefore, potentially affected by the following vulnerabilities :

- An unspecified error exists that could allow a buffer overflow leading to code execution. (CVE-2013-0633)

- An unspecified error exists that could allow memory corruption leading to code execution. (CVE-2013-0634)

Solution

Upgrade to Adobe Flash Player version 10.3.183.51 / 11.5.502.149 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb13-04.html

Plugin Details

Severity: High

ID: 64507

File Name: macosx_flash_player_11_5_502_149.nasl

Version: 1.11

Type: local

Agent: macosx

Published: 2013/02/08

Updated: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/02/07

Vulnerability Publication Date: 2013/02/07

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Adobe Flash Player Regular Expression Heap Overflow)

Reference Information

CVE: CVE-2013-0633, CVE-2013-0634

BID: 57787, 57788