LogAnalyzer userchange.php 'viewid' Parameter XSS

Medium Nessus Plugin ID 64486

Synopsis

The remote web server hosts a PHP script that is affected by a
cross-site scripting vulnerability.

Description

The LogAnalyzer install hosted on the remote web server is affected by
a cross-site scripting vulnerability due to a failure to properly
sanitize user input to the 'viewid' parameter of the 'userchange.php'
script. An attacker can exploit this issue to inject arbitrary HTML
and script code into a user's browser to be executed within the
security context of the affected site.

Solution

Upgrade to version 3.6.2 or later.

See Also

http://www.nessus.org/u?2319a239

Plugin Details

Severity: Medium

ID: 64486

File Name: loganalyzer_viewid_parameter_xss.nasl

Version: 1.6

Type: remote

Published: 2013/02/06

Modified: 2018/11/15

Dependencies: 62122

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adiscon:loganalyzer

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/09

Vulnerability Publication Date: 2013/01/09

Reference Information

BID: 57248

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990