Wireshark 1.6.x < 1.6.13 Multiple Vulnerabilities

High Nessus Plugin ID 64361

Synopsis

The remote Windows host contains an application that is affected by multiple vulnerabilities.

Description

The installed version of Wireshark 1.6 is earlier than 1.6.13. It is, therefore, affected by the following vulnerabilities :

- Errors exist related to the Bluetooth HCI, CSN.1, DCP-ETSI DOCSIS CM-STAUS, IEEE 802.3 Slow Protocols, MPLS, R3, RTPS, SDP, and SIP dissectors that could allow the application to enter infinite or large loops, thereby consuming excessive CPU resources. (Bugs 8036, 8037, 8038, 8040, 8041, 8042, 8043, 8198, 8199, 8222)

- Errors exist related to the DCP-ETSI, DTLS, MS-MMC, DTN, CLNP dissectors that could allow them to crash.
(Bugs 7871, 7945, 8111, 8112, 8213)

- An unspecified error could allow the dissection engine to crash. (Bug 8197)

- An unspecified buffer overflow exists in the NTLMSSP dissector that has an unspecified impact.

Solution

Upgrade to Wireshark version 1.6.13 or later.

See Also

https://www.wireshark.org/security/wnpa-sec-2013-01.html

https://www.wireshark.org/security/wnpa-sec-2013-02.html

https://www.wireshark.org/security/wnpa-sec-2013-03.html

https://www.wireshark.org/security/wnpa-sec-2013-04.html

https://www.wireshark.org/security/wnpa-sec-2013-05.html

https://www.wireshark.org/security/wnpa-sec-2013-07.html

https://www.wireshark.org/security/wnpa-sec-2013-08.html

https://www.wireshark.org/security/wnpa-sec-2013-09.html

https://www.wireshark.org/docs/relnotes/wireshark-1.6.13.html

Plugin Details

Severity: High

ID: 64361

File Name: wireshark_1_6_13.nasl

Version: 1.9

Type: local

Agent: windows

Family: Windows

Published: 2013/01/30

Updated: 2018/11/15

Dependencies: 34112

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/29

Vulnerability Publication Date: 2013/01/29

Reference Information

CVE: CVE-2013-1572, CVE-2013-1573, CVE-2013-1574, CVE-2013-1575, CVE-2013-1576, CVE-2013-1577, CVE-2013-1578, CVE-2013-1579, CVE-2013-1580, CVE-2013-1581, CVE-2013-1582, CVE-2013-1583, CVE-2013-1584, CVE-2013-1585, CVE-2013-1586, CVE-2013-1588, CVE-2013-1589, CVE-2013-1590

BID: 57615, 57616, 57618, 57620, 57621, 57622, 57625, 57626, 57647