AIX 6.1 TL 4 : qosmod (IZ68231)

High Nessus Plugin ID 64354

Synopsis

The remote AIX host is missing a security patch.

Description

There is a buffer overflow vulnerability in the qosmod command. A locally authenticated attacker can exploit this vulnerability if they have they have been assigned the aix.network.config.no role-based access control authorization.

The successful exploitation of this vulnerability allows a local attacker to execute arbitrary code with the innate privileges of the qosmod command.

The following executable is vulnerable :

/usr/sbin/qosmod.

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/qosmod_advisory.asc

Plugin Details

Severity: High

ID: 64354

File Name: aix_IZ68231.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/01/30

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:ibm:aix:6.1

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Patch Publication Date: 2010/03/05

Vulnerability Publication Date: 2010/03/05

Reference Information

CVE: CVE-2010-0960