AIX 6.1 TL 1 : libC (IZ56204)

High Nessus Plugin ID 64342

Synopsis

The remote AIX host is missing a security patch.

Description

There is a an error in the handling of the _LIB_INIT_DBG and
_LIB_INIT_DBG_FILE environment variables in a debugging component of the XL C++ runtime library. A local user can exploit this error when executing setuid root programs linked with the XL C++ runtime library, and thereby create arbirtrary, world writeable files owned by root.

The successful exploitation of this vulnerability allows a local user to create arbitrary files and execute arbitrary code as the root user.

Note that in AIX 6.1 the debugging component moved from libC.a to libc.a. This means that the fix is delivered by updating the XL C++ runtime on AIX 5.3 and earlier, and by updating the bos.rte.libc fileset on AIX 6.1.

The following libraries are vulnerable :

AIX 5.3 and earlier: /usr/lpp/xlC/lib/libC.a

AIX 6.1: /usr/ccs/lib/libc.a /usr/ccs/lib/libp/libc.a.

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/libC_advisory.asc

Plugin Details

Severity: High

ID: 64342

File Name: aix_IZ56204.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/01/30

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:ibm:aix:6.1

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Patch Publication Date: 2009/08/04

Vulnerability Publication Date: 2009/08/04

Reference Information

CVE: CVE-2009-2669

CWE: 264