AIX 5.3 TL 0 : pioout (IZ10841)

High Nessus Plugin ID 64311

Synopsis

The remote AIX host is missing a security patch.

Description

Buffer overflow vulnerabilities exist in the 'printers.rte' fileset commands listed below. A local attacker may execute arbitrary code with root privileges because the commands are setuid root.

The following commands are vulnerable :

/usr/lib/lpd/pio/etc/pioout The fix for piomkpq for IZ01121 and IZ01122 was not included with this fix package, therefore it has been repackged and included as described below. A local attacker who is a member of the printq group may execute arbitrary code with root privileges because the piomkpq command is setuid root. The following command is vulnerable: /usr/lib/lpd/pio/etc/piomkpq.

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/pioout_advisory.asc

Plugin Details

Severity: High

ID: 64311

File Name: aix_IZ10841.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/01/30

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:ibm:aix:5.3

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2008/01/22

Vulnerability Publication Date: 2008/01/22

Reference Information

CVE: CVE-2007-5764

CWE: 119