AIX 5.3 TL 5 : perl (IZ10244)

High Nessus Plugin ID 64309

Synopsis

The remote AIX host is missing a security patch.

Description

A buffer overflow vulnerability exists in the 'perl.rte' fileset. A remote attacker may execute arbitrary code if a Perl script executing on the system is listening on a network port. If exploited the attacker can execute arbitrary code with the same privileges as the script.

For more details please visit :

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5116

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/perl_advisory.asc

Plugin Details

Severity: High

ID: 64309

File Name: aix_IZ10244.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/01/30

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:ibm:aix:5.3

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Patch Publication Date: 2007/12/18

Vulnerability Publication Date: 2007/12/18

Reference Information

CVE: CVE-2007-5116

CWE: 119