AIX 5.3 TL 12 : perl (IV10197)

High Nessus Plugin ID 64299

Synopsis

The remote AIX host is missing a security patch.

Description

The Digest module for Perl is prone to a vulnerability that will let attackers inject and execute arbitrary Perl code.

Remote attackers can exploit this issue to run arbitrary code in the context of the affected application.

Digest versions prior to 1.17 are affected.

For more details please visit :

http://www.securityfocus.com/bid/49911 https://secunia.com/advisories/46279

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/perl_advisory2.asc

Plugin Details

Severity: High

ID: 64299

File Name: aix_IV10197.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/01/30

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/o:ibm:aix:5.3

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Patch Publication Date: 2011/11/22

Vulnerability Publication Date: 2011/11/22

Reference Information

CVE: CVE-2011-3597