SuSE 11.1 Security Update : socat (SAT Patch Number 6407)

Medium Nessus Plugin ID 64225


The remote SuSE 11 host is missing a security update.


This update fixes two small security issues in socat :

- Fixed a stack overflow in commandline parsing (bnc#627475 / CVE-2010-2799) Only exploitable if an attacker can control the commandline parameters.

- Fixed heap overflow in READLINE output mode (bnc#759859 / CVE-2012-0219)


Apply SAT patch number 6407.

See Also

Plugin Details

Severity: Medium

ID: 64225

File Name: suse_11_socat-120611.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2013/01/25

Modified: 2013/10/25

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:socat, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2012/06/11

Reference Information

CVE: CVE-2010-2799, CVE-2012-0219