SuSE 11.1 Security Update : java-1_6_0-openjdk (SAT Patch Number 6437)

Critical Nessus Plugin ID 64167

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

java-1_6_0-openjdk was updated to the IcedTea 1.11.3 release, fixing multiple security issues :

- S7079902, CVE-2012-1711: Refine CORBA data models

- S7143606, CVE-2012-1717: File.createTempFile should be improved for temporary files created by the platform.

- S7143614, CVE-2012-1716: SynthLookAndFeel stability improvement

- S7143617, CVE-2012-1713: Improve fontmanager layout lookup operations

- S7143851, CVE-2012-1719: Improve IIOP stub and tie generation in RMIC

- S7143872, CVE-2012-1718: Improve certificate extension processing

- S7152811, CVE-2012-1723: Issues in client compiler

- S7157609, CVE-2012-1724: Issues with loop

- S7160757, CVE-2012-1725: Problem with hotspot/runtime_classfile

Solution

Apply SAT patch number 6437.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=766802

http://support.novell.com/security/cve/CVE-2012-1711.html

http://support.novell.com/security/cve/CVE-2012-1713.html

http://support.novell.com/security/cve/CVE-2012-1716.html

http://support.novell.com/security/cve/CVE-2012-1717.html

http://support.novell.com/security/cve/CVE-2012-1718.html

http://support.novell.com/security/cve/CVE-2012-1719.html

http://support.novell.com/security/cve/CVE-2012-1723.html

http://support.novell.com/security/cve/CVE-2012-1724.html

http://support.novell.com/security/cve/CVE-2012-1725.html

Plugin Details

Severity: Critical

ID: 64167

File Name: suse_11_java-1_6_0-openjdk-120615.nasl

Version: Revision: 1.4

Type: local

Agent: unix

Published: 2013/01/25

Updated: 2013/11/18

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk, p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk-demo, p-cpe:/a:novell:suse_linux:11:java-1_6_0-openjdk-devel, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/06/15

Exploitable With

Core Impact

Metasploit (Java Applet Field Bytecode Verifier Cache Remote Code Execution)

Reference Information

CVE: CVE-2012-1711, CVE-2012-1713, CVE-2012-1716, CVE-2012-1717, CVE-2012-1718, CVE-2012-1719, CVE-2012-1723, CVE-2012-1724, CVE-2012-1725