SuSE 11.2 Security Update : IBM Java (SAT Patch Number 6793)

Critical Nessus Plugin ID 64165

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

IBM Java 1.5.0 was updated to SR11 which fixes bugs and security issues.

http://www.ibm.com/developerworks/java/jdk/alerts/

Also three bugs have been fixed :

- fix bnc#771808: create symlink /usr/bin/javaws properly

- fix bnc#666744: mark all configuration files as %config(noreplace)

- fix bnc#773021: add code removing fonts symlink to baselibs.conf

Solution

Apply SAT patch number 6793.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=666744

https://bugzilla.novell.com/show_bug.cgi?id=771808

https://bugzilla.novell.com/show_bug.cgi?id=773021

https://bugzilla.novell.com/show_bug.cgi?id=778629

http://support.novell.com/security/cve/CVE-2012-0551.html

http://support.novell.com/security/cve/CVE-2012-1713.html

http://support.novell.com/security/cve/CVE-2012-1716.html

http://support.novell.com/security/cve/CVE-2012-1717.html

http://support.novell.com/security/cve/CVE-2012-1718.html

http://support.novell.com/security/cve/CVE-2012-1719.html

http://support.novell.com/security/cve/CVE-2012-1721.html

http://support.novell.com/security/cve/CVE-2012-1722.html

http://support.novell.com/security/cve/CVE-2012-1725.html

Plugin Details

Severity: Critical

ID: 64165

File Name: suse_11_java-1_6_0-ibm-120907.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2013/01/25

Updated: 2019/10/16

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:java-1_6_0-ibm, p-cpe:/a:novell:suse_linux:11:java-1_6_0-ibm-alsa, p-cpe:/a:novell:suse_linux:11:java-1_6_0-ibm-fonts, p-cpe:/a:novell:suse_linux:11:java-1_6_0-ibm-jdbc, p-cpe:/a:novell:suse_linux:11:java-1_6_0-ibm-plugin, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/09/07

Reference Information

CVE: CVE-2012-0551, CVE-2012-1713, CVE-2012-1716, CVE-2012-1717, CVE-2012-1718, CVE-2012-1719, CVE-2012-1721, CVE-2012-1722, CVE-2012-1725