RHEL 3 : Adobe Acrobat Reader (RHSA-2007:0021)

High Nessus Plugin ID 63836


The remote Red Hat host is missing one or more security updates.


Updated acroread packages that fix several security issues are now available for Red Hat Enterprise Linux 3.

This update has been rated as having critical security impact by the Red Hat Security Response Team.

[Updated 23 Jan 2007] The previous acroread packages were missing dependencies on the new libraries which could prevent acroread from starting. Replacement acroread packages have been added to this erratum to correct this issue.

The Adobe Reader allows users to view and print documents in portable document format (PDF).

A cross site scripting flaw was found in the way the Adobe Reader Plugin processes certain malformed URLs. A malicious web page could inject arbitrary javascript into the browser session which could possibly lead to a cross site scripting attack. (CVE-2007-0045)

Two arbitrary code execution flaws were found in the way Adobe Reader processes malformed document files. It may be possible to execute arbitrary code on a victim's machine if the victim opens a malicious PDF file. (CVE-2006-5857, CVE-2007-0046)

Please note that Adobe Reader 7.0.9 requires versions of several system libraries that were not shipped with Red Hat Enterprise Linux 3. This update contains additional packages that provide the required system library versions for Adobe Reader. These additional packages are only required by Adobe Reader and do not replace or affect any other aspects of a Red Hat Enterprise Linux 3 system.

All users of Adobe Reader are advised to upgrade to these updated packages, which contain Adobe Reader version 7.0.9 and additional libraries to correct these issues.


Update the affected packages.

See Also






Plugin Details

Severity: High

ID: 63836

File Name: redhat-RHSA-2007-0021.nasl

Version: $Revision: 1.7 $

Type: local

Agent: unix

Published: 2013/01/24

Modified: 2017/01/10

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:acroread, p-cpe:/a:redhat:enterprise_linux:acroread-libs-atk, p-cpe:/a:redhat:enterprise_linux:acroread-libs-glib2, p-cpe:/a:redhat:enterprise_linux:acroread-libs-gtk2, p-cpe:/a:redhat:enterprise_linux:acroread-libs-gtk2-engines, p-cpe:/a:redhat:enterprise_linux:acroread-libs-pango, p-cpe:/a:redhat:enterprise_linux:acroread-plugin, cpe:/o:redhat:enterprise_linux:3

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/01/23

Vulnerability Publication Date: 2006/12/27

Exploitable With

Core Impact

Reference Information

CVE: CVE-2006-5857, CVE-2007-0045, CVE-2007-0046

OSVDB: 31046, 31048, 31316

RHSA: 2007:0021

CWE: 399