AIX 5.3 TL 0 : lsmcode (IZ15100)

High Nessus Plugin ID 63754

Synopsis

The remote AIX host is missing a security patch.

Description

The lsmcode command contains an environment variable handling error. A local attacker may exploit this error to execute arbitrary code with root privileges because the command is setuid root.

The following files are vulnerable :

/usr/sbin/lsmcode.

Solution

Install the appropriate interim fix.

See Also

http://aix.software.ibm.com/aix/efixes/security/lsmcode_advisory.asc

Plugin Details

Severity: High

ID: 63754

File Name: aix_IZ15100.nasl

Version: $Revision: 1.2 $

Type: local

Published: 2013/01/24

Modified: 2013/03/11

Dependencies: 12634

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: cpe:/o:ibm:aix:5.3

Required KB Items: Host/AIX/lslpp, Host/local_checks_enabled, Host/AIX/version

Patch Publication Date: 2008/03/11

Vulnerability Publication Date: 2008/03/11

Reference Information

CVE: CVE-2008-1600

CWE: 264