Apache CouchDB < 1.0.4 / 1.1.2 / 1.2.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 63642


The remote database server is potentially affected by multiple vulnerabilities.


According to its banner, the version of CouchDB running on the remote host is earlier than 1.0.4, 1.1.x earlier than 1.1.2 or 1.2.x earlier than 1.2.1. It is, therefore, potentially affected by the following vulnerabilities :

- An unspecified error exists in the included MochiWeb HTTP library that can allow access to arbitrary files via directory traversal attacks. Note that reportedly, this issue only affects installs on Windows hosts.

- An error related to JSONP callbacks can allow an unspecified cross-site scripting attack. (CVE-2012-5649)

- An input validation error exists related to unspecified query parameters and the Futon UI that can allow DOM- based cross-site scripting attacks. (CVE-2012-5650)

Note that Nessus did not actually test for these flaws but instead, has relied on the version in CouchDB's banner.


Upgrade to CouchDB 1.0.4 / 1.1.2 / 1.2.1 or later.

See Also




Plugin Details

Severity: Medium

ID: 63642

File Name: couchdb_1_2_1.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 2013/01/22

Updated: 2019/12/04

Dependencies: 51922

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2012-5649

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:couchdb

Required KB Items: Settings/ParanoidReport, www/couchdb

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/01/14

Vulnerability Publication Date: 2013/01/14

Reference Information

CVE: CVE-2012-5641, CVE-2012-5649, CVE-2012-5650

BID: 57313, 57314, 57321

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990