PostgreSQL 7.4 < 7.4.27 / 8.0 < 8.0.23 / 8.1 < 8.1.19 / 8.2 < 8.2.15 / 8.3 < 8.3.9 / 8.4 < 8.4.2 Multiple Vulnerabilities

Medium Nessus Plugin ID 63348

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 7.4 prior to 7.4.27, 8.0 prior to 8.0.23, 8.1 prior to 8.1.19, 8.2 prior to 8.2.15, 8.3 prior to 8.3.9 or 8.4 prior to 8.4.2. As such, it is potentially affected by multiple vulnerabilities :

- NULL bytes in SSL Certificates can be used to falsify client or server authentication. (CVE-2009-4034)

- Privilege escalation is possible via changing session state in an index function. (CVE-2009-4136)

Solution

Upgrade to PostgreSQL 7.4.27 / 8.0.23 / 8.1.19 / 8.2.15 / 8.3.9 / 8.4.2 or later.

See Also

https://www.postgresql.org/about/news/1170/

https://www.postgresql.org/docs/7.4/release-7-4-27.html

https://www.postgresql.org/docs/8.0/release-8-0-23.html

https://www.postgresql.org/docs/8.1/release-8-1-19.html

https://www.postgresql.org/docs/8.2/release-8-2-15.html

https://www.postgresql.org/docs/8.3/release-8-3-9.html

https://www.postgresql.org/docs/8.4/release-8-4-2.html

Plugin Details

Severity: Medium

ID: 63348

File Name: postgresql_20091214.nasl

Version: 1.8

Type: local

Family: Databases

Published: 2012/12/28

Updated: 2018/11/15

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/12/14

Vulnerability Publication Date: 2009/12/14

Reference Information

CVE: CVE-2009-4034, CVE-2009-4136

BID: 37333, 37334

CWE: 310