The remote database server is affected by multiple vulnerabilities.
The version of PostgreSQL installed on the remote host is 7.4 prior to 7.4.27, 8.0 prior to 8.0.23, 8.1 prior to 8.1.19, 8.2 prior to 8.2.15, 8.3 prior to 8.3.9 or 8.4 prior to 8.4.2. As such, it is potentially affected by multiple vulnerabilities : - NULL bytes in SSL Certificates can be used to falsify client or server authentication. (CVE-2009-4034) - Privilege escalation is possible via changing session state in an index function. (CVE-2009-4136)
Upgrade to PostgreSQL 7.4.27 / 8.0.23 / 8.1.19 / 8.2.15 / 8.3.9 / 8.4.2 or later.