MariaDB 5.5 < 5.5.28a Buffer Overflow

Medium Nessus Plugin ID 63150


The remote database server is affected by a buffer overflow vulnerability.


The version of MariaDB 5.5 running on the remote host is prior to 5.5.28a. It is, therefore, affected by a buffer overflow vulnerability. A remote, authenticated attacker can exploit this to execute arbitrary code.


Upgrade to MariaDB version 5.5.28a or later.

See Also

Plugin Details

Severity: Medium

ID: 63150

File Name: mariadb_5_5_28a.nasl

Version: 1.17

Type: remote

Family: Databases

Published: 2012/12/04

Updated: 2018/11/15

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/11/29

Vulnerability Publication Date: 2012/11/29

Reference Information

CVE: CVE-2012-5611

BID: 56769

EDB-ID: 23075