MariaDB 5.3 < 5.3.11 Buffer Overflow

medium Nessus Plugin ID 63149
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by a buffer overflow vulnerability.

Description

The version of MariaDB 5.3 running on the remote host is prior to 5.3.11. It is, therefore, affected by a buffer overflow vulnerability.
A remote, authenticated attacker could exploit this to execute arbitrary code.

Solution

Upgrade to MariaDB version 5.3.11 or later.

See Also

https://seclists.org/fulldisclosure/2012/Dec/4

https://mariadb.com/kb/en/library/mariadb-5311-release-notes/

Plugin Details

Severity: Medium

ID: 63149

File Name: mariadb_5_3_11.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 12/4/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/29/2012

Vulnerability Publication Date: 11/29/2012

Reference Information

CVE: CVE-2012-5611

BID: 56769

EDB-ID: 23075